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TUTORIAL I -  WORKING WITH DMAGIC 

DMagic 
Introduction 

Magic is used as a supporting application to Fledermaus.  Its primary purpose is to 
prepare surfaces for visualization in Fledermaus, however it also provides a 
number of data analysis and visual exploration tools. 

 

P U R P O S E  
 

Throughout this tutorial you will: 
 

1. Open a project 
2. Import surfaces 
3. Import an image 
4. Texture map DTM’s 
5. Export to ASCII file 
6. Compute slopes 
7. Use scalers 

 

 

I 

D 
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1 Working with Projects 

1.1 Exercise - Loading a Project 

In this exercise you will become familiar with the DMagic interface while loading a 
project.  
Loading a project is the first step in working with the many types of gridded data 
sets.  
 
Hint: A project in DMagic is really just a directory that may or may not contain files 
of interest to DMagic. The active project directory is always shown in the 
application title bar as “DMagic: <Directory Name>”. 
 
Note: The first part of this exercise is going to highlight some common 
user errors when using DMagic. Make note of the results so when you 
start using DMagic on your own, you can identify these. 
 
1. :Start DMagic 

 
The DMagic user interface is divided into four major regions.  Control Region, 
Surface Display, Color Map and Analysis Tool.   
 
The main files used in DMagic are the DTM file for height, the shaded imagery or 
shade file and georeferencing geo file. The directory these are stored in are referred 
to as a project. 
 

2. :Select Project > Open Project > Module3_DMAGIC > 
Tutorial1_1 
This will make the Tutorial1_1 directory active and you will now see Area1.DTM, 
Area1.shade and Area1.geo displayed in the Control Region (upper left hand part of 
screen). 
 

3. :Select any file in the data component list and click the small 
question mark button to the right of the file list   
This button brings up the TDR File Browser where you can view the attributes. 

 
4. :Highlight each of the files in the component list to view its 

attributes 
 
5. :Click on Close Browser to close the TDR File Browser 

 
6. :Load the DTM into the visualization window by highlighting the 

DTM file and clicking the single arrow button. This is only going to 
load the DTM without georeferencing information or shade imagery. 
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7. :Move the mouse over the data and try panning and zooming. 
Try using the right mouse button as well to create a profile. Since 
there is no georeferencing loaded, the software doesn’t have enough 
information to display real world coordinates. You should note 
“information not available” in the position field. 
 

8. :Click the Cmap Librarian button on the lower right of the 
window. The Cmap Librarian allows you to load a new color map 
in DMagic. Scroll through and select any colourmap from the 
available colormaps.  Note the scale used by the color bar. Since the 
georeferencing is not available to the software, the color bar can’t 
constrain color information with elevation data, thus without 
georeferencing loaded you will only see a range from 0 – 255. 
 

9. :Now select the tabs to look at the Shaded Imagery and Scalar 
work areas.  Since this information hasn’t been loaded it is not available. 
The Scalar Field and Shaded Imagery work areas will be blank. 

 
10. :Highlight Area1.DTM and click the double arrow and repeat 

steps 8 & 9. You will see that the view switches to the Shaded Imagery 
data. 

 
Note: Now that the geo file has been applied:  1. you are able to 
profile using the right mouse button; 2. you can view the Shaded 
Imagery and Scaler Field; and, 3. the Cmap is now showing the 
correct Z range from the geo file. 
 

1.2 Exercise - Creating a .sd file from .dtm, .geo & 
.shade files 

Data Input:  Ps_lidar.dtm,geo  Data Output: several DTMs, shade and geo files 
   Data courtesy of NOAA 

    
This short exercise will expand on what you learned in the last exercise and 
actually create a file viewable in Fledermaus. 

 
1.  :Open project and navigate to: Module3_DMAGIC 

\Tutorial1_2\  
You’ll notice that there is only a .dtm and .geo file in the project. This is 
correct, as we are going to generate the shade file ourselves. It is not usually 
necessary to keep the shade file around if you are looking to save disk space. 
You can recreate the shade file on command, like we are about to do. 
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2.  :Double arrow load any of the ps_lidar files to load the entire 
set 

 
3. :Use the Colourmap Librarian to select an appealing 

colourmap 
 
4. :Now select the “Surface Shader” button  

This will bring up the shadar dialogue box. Don’t worry right now about the 
settings so much, but do feel free to play. Setting each of the sliders to the 
minimum and maximum values to exaggerate the effect of each parameter. 
Note that you will have to press the ‘Start Rendering’ button before you will 
see your settings take effect. 

 
5. :When you are happy with the shade settings, click the “Start 

Rendering”  
You’ll notice the “Render Status” field says rendering. 
Note: if at anytime you need to stop rendering, click the stop rendering 
button. You can always restart by clicking the “Start Rendering” button 
again.  When the rendering operation is finished the “Render Status” field 
should indicate finished and a full shaded image should appear in the 
rendering window. 

 
6. :Click the save shade button, then click the close button to 

exit the shade window. By default it will be named after the dtm file 
loaded at the time you started shading. 

 
7. :Now you have all of the parts needed to create an .sd file. We 

will start by clicking the Assemble Fledermaus Objects button.  
 
8. :By default the base name of the dtm you are trying to use 

will be the output name of the sd. This name should be fine for 
our purposes. When you are happy with the settings, click the 
build object button. Ps_lidar.sd should appear in the 
Fledermaus objects window 

 
9. :Click the Run Fledermaus button to take a look at your new 

.sd file   
 

1.3 Exercise - Loading a Project: Data Manipulation 
& I/O 

Data Input:  sd file  Data Output: several DTMs, shade and geo files 
 
This is a more advanced exercise in loading and manipulating a project from an sd 
file; and is the first step of working with any type of gridded data set. This exercise 
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will show you how to customize data, to optimize how data will look, and then 
create a file for use in Fledermaus. 
 

1. :Open project Module3_DMAGIC \Tutorial1_3\ 
 
2. :Select the “Import From SD” option on the project menu. Select 

Module3_DMAGIC \Tutorial1_3\8125.utm.sd file. The data blocks 
(dtm, shade and geo) will be extracted from the sd file, so it may take a few 
moments. 

 
3. :Select any file in the Data Components window. Click the 

double arrow placing the data into the visualization window and 
change the color map file. 

 
4. :Click on the Surface Shader button. Click on the Start Rendering 

button to complete the shading. Explore the various shading 
parameters 

 
5. : When you have found an appealing setting, select Shade 

Manager to save the shade settings to a parameter file (spf).  Save 
the shade file by typing in a name in Shade Config Name and click 
on the Save Current Config button. Now mess around with the 
shade parameters and re-shade and then reopen the Shade 
Manager dialogue and reload the spf file you just created. Click 
OK and Start Rendering to see the changes. Without rendering you 
won’t see the affect of the changes. This should restore your 
settings to the saved values.  

 
If you want to save the shade with the color map choice you 
selected in #3 above, click on the Save Shade button and either 
replace the existing shade or create a new shade file name by 
typing a name in the Output File field.  Click on Close to close the 
Surface Shader window. 

 
6. : Select the subset tool, the button with the scissor icon on it. Pick 

an interesting section of the DTM and using the left button make a 
small square around the selected area.  

 
7. :Click the right button to open the Bounds Entry Dialog.  Ensure 

the Custom Min/Max is selected and click on the Extract button.  
Save the file with the base name of 8125small1. To see the effect of 
this operation check out the geo file for the dataset you have just 
created. à Click on the .geo file and the question mark button. 
(Write down the X & Y bounds for a following exercise). 
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8. :Reload 8125.utm.dtm so that we can investigate other subset 
methods. 

 
9. :Under Tools, use Export Region and extract a subset of the 

8125.utm.dtm file by typing in the coordinates (Custom Min/Max) 
that match the bounds of 8125small1 above. Name this subset 
8125small2. 
 

10. :Now save these new datasets as sd files.  Click on the Assemble 
Fledermaus Objects button and create sd files by selecting each 
file separately in the Height Object field and clicking the Build 
Object button. When completed, click the Close button. 

 
11. :Select one of your newly created sd files and click on Run 

Fledermaus to examine the new dataset. Repeat to view the others. 

1.4 Exercise - Importing Surfaces 

Data Input: mountains.xyz Data Output:  DTM/scalar and geo file 
 
This operation allows the user to import a surface into DMagic and convert it into a 
DTM or an SD file; or export it as an ASCII file.  
  
This procedure is useful for bringing in grid types created from other software 
packages or gridded ASCII data. This operation can also be a part of the process 
(along with export xyz) of converting a surface into an ASCII file.  
 
1. :Start DMagic  
 
2. :Select File > Import Surface 
 
3. :Use the browser field to select Module3_DMAGIC  > 

Tutorial1_4 > mountains.xyz and click the open button  
 
4. :Put focus on the Importing Surface window. From the file type, 

select the import file type from the ‘Choose File Type’ pull down 
box. In this instance we are loading a grd file and should select the 
ASCII Gridded Data option. 

 
The context of the box is file type sensitive so different parameters will be required 
for different file types.  For this example, choosing ASCII gridded you will be 
prompted for the following information.  
 

5. :In the ‘File Type Specific Options’ enter the number of rows and 
columns. In this case it will be 437 X 564 respectively. 
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6. :Once the data below is entered, the file can be scanned. Select 

“Scan For Information”  Appropriate data will automatically be input in the 
empty fields below. 

 
§ The user can specify if the file is just z values or if there are more fields and 

what order those fields will be in. Select “XYZ Variables”.  
§ Use Special Value – The user can also specify if the grid denotes missing 

points with special value that the software is to treat as blank. We will not be 
using special values. 

§ Skip Header Lines – If there are any header lines in the file, the number 
of lines to skip can be specified by the user as well. There is no header in 
this example. 

§ Handle Missing Points – If there are just missing points, a cell size can be 
specified so that the software can tell that not all the cells have a value and 
create a DTM of the correct proportions. We do not need to use this.  

 
If the numbers match the bounds of the data and the correct number of rows and 
columns appear, then the data can be exported as a DTM (z values are used to 
denote elevation values of a surface) or as a scalar – another quality or quantity 
attached to the surface).  

 
7. :To save the new file, select ‘Convert and Save File’.  A file dialog 

box will appear.  You can save using the base name of mountains, 
the file extensions will be added automatically. 

 
8. :Using what you have learned so far, construct an .sd file and 

view in Fledermaus. 

1.5 Exercise - Texture Mapping 

Data Input:  NWCape.* (SD file, raster image and georeferencing) Data Output: 
SD file 

 
This operation allows the user to map a high-resolution image file to a lower 
resolution surface.  The operation also computes and extracts the overlapping 
regions of the SD and image files. 
   
This procedure can be highly effective in merging maps, aerial photography and 
remotely sensed data with underlying topographic data. It is also used to drape high-
resolution sonar images over bathymetric models. 
 
This approach is beneficial because it allows higher resolution features to be 
mapped to the DTM data, without inflating the size of the DTM file beyond its 
native resolution. The result is a visually appealing 3D object that requires lower 
system resources when loaded in Fledermaus. 
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1. :Start DMagic. 

 
2. :Select Project >Open Project and navigate to 

Module3_DMAGIC > Tutorial1_6  
 

3. : Select File > Import Imagery > Create Textured SD file  
 

4. :You will now see a Create Textured SD File window appear. 
 

5. :Select NWCape_geo.tif in the image file field. 
 

6. :If the image is a geotiff or has an associated world file, the image 
bounds should appear in the image boundary. In this case we are 
dealing with a geotif image and you should see a set of bounding 
coordinate appear in the Image Boundary fields.  

X min: 160174.66,  max: 282544.66 
Y min: 7523357.37  max : 7592447.37 

 
In some circumstances the byte order might not be correct, which usually results 
in a red looking image. If this is the case, press the reverse image byte order 
button. 

 
7. :Select the inputSD File. This operation requires a constructed 

.sd file to operate. We will be using NWCape.sd. If one had not been 
constructed yet, you would have to create a temporary one by importing the 
shading with the default colourmap. The output of the texturemapping 
operation supercedes the shade information anyway. 

 
8. :Select the output .sd file to create. Let’s call this file 

NWCape_tex.sd. Remember, this is producing a file that will be 
directly viewable in Fledermaus. 

 
9. :When the operation is complete start Fledermaus and load the 

.sd file. 
 

E X T R A  C R E D I T : 
In the extra_credit folder you will find: 

Newscotland.sd scotlandLo.tif  scotlandLo.tfw 

With this data import the image and texturemap in on to the surface. 
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1.6 Exercise - Importing an Image into DMagic 

 
Data Input:  NWCape.* (DTM, raster image and georeferenceing)  
Data Output:  DTM, geotif, geofile 
 
This operation allows the user to import an image into DMagic and extract a subset 
from a coincident DTM. This operation is used to produce an SD file based on 
thematic data and to produce components for texture mapping. You will also learn 
how to import images into Fledermaus. 
  
This procedure can be highly effective in merging maps, aerial photography and 
remotely sensed data with underlying topographic data.  
 
1. :Start DMagic > Open Project and select: Module3_DMAGIC 

\Tutorial1_5\ 
 
2. : Select File > Import Surface > Module3_DMAGIC  > 

Tutorial1_5 > NWCape.ers  
(use the steps from the last exercise making note that we are using an ermapper 
file this time, i.e. ER Mapper Grid and save it as NWCape.) 

 
3. : Select File > Import Imagery > Cut and Drape Imagery. 

 
4. :Use the browser field to select NWCape_geo.tif  
 

You may select either to: rescale image to DTM size or match georeferenced regions 
and rescale DTM to image resolution.  

 
§ Selecting to rescale the image assumes that the image and DTM are the same 

aspect ratio. If this is not the case, the resulting image will be distorted. Doing 
this now would not be a good idea. 

 
§ Selecting match georeferenced regions and rescaling DTM will upsample the 

DTM to the resolution of the image and will discard any areas where both DTM 
and imagery data do not exist. This is usually a safe choice, especially if you are 
unfamiliar with the data. 

 
§ NOTE:  If the image is not a geotiff, or has no world (tfw) file, georeferencing 

needs to be added in the georeferencing fields.  
 
5. :Select >  Match georeferenced regions and rescaling DTM to 

image resolution 
 
6.  :Select an Output File Base Name for the resulting data. By 

default, a ‘–out’ is appended to the file name  
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7. :Finally select the > DTM to Process,  from the list box of DTMs 
contained in the project directory. Select the NWCape.dtm file. 

 
8. :Click the OK button. This process generates several new files 

with the base name of NWCape-out. There will also be a tif file 
created (but not shown on in the component list) for use in step 10. 

 
9. :Click on the double arrow to load the new (-out) DTM   

 
10. :Click on Surface Shader and overlay the image by selecting the 

overlay image button and loading the –out.tif file you created  
 

11. :Render and save your shade file 
 

12. :Create .SD and load into Fledermaus. 
 

13. :To improve the visualization of this dataset, we will import the 
geotiff into Fledermaus as well to represent the water surface and 
obscured seafloor. 

 
14. :Select file>import image file. 

 
15. :Select NWcape_geo.tif. 

 
16. :Save this as a scene. 
  

 
  

1.7 Exercise - Exporting to ASCII 

Data Input:  Denver_w.dem  Data Output:  ASCII xyz/z file 
 
This operation allows the user to export a DTM to an ASCII xyz file. Used to 
convert tdr files into a standard (albeit inefficient) format.  
  
ASCII files are probably the most universal and platform independent format used 
for data exchange.  
 
We will start this exercise by reviewing the import of other file types: 
 
1. :Start DMagic 
 
2. :Select Project>Open Project and navigate to 

Module3_DMAGIC >Tutorial1_7 
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3. :Select File > Import Surface and import Module3_DMAGIC  > 

Tutorial1_7 > Denver_w.dem  
 

4. :Save the import as a DTM, i.e. to Denver_w.dtm and geo.  Note 
that this is a USGS DEM file, so make sure you select the proper converter. 
Review tutorial 1_4 if you get stuck. 

 
5. :Load DTM and geo by selecting one of the Denver_w files and 

clicking the ‘>>’ button. 
 

6. :Select File > Export Surface 
 

An ‘export xyz…’ window will open and allow you to select several formats and 
ways to deal with missing data.  
 
Export z values produces an ASCII grid of z values, which provides a space saving 
of 2/3rds compared to xyz format. You can also export an Arcview format ASCII 
grid. The Export binary heights produce an 8/16/32 bit binary (not comparable to 
avggrid binary grids), which should provide a significant savings in filesize at the cost 
of portability.  

 
7. :Once the format and name has been chosen, click Save to write 

the file. Save as “denver_w.asc” 
 

1.8 Exercise - Computing Slopes 

Data Input:  MntStHelens.*  Data Output:  scalar 
 
This operation allows the user to derive a scalar based on slope. The scalar can be 
used to color the DTM as well.  
 
This procedure can be highly effective in emphasising discrete features in surfaces 
(such as fault traces on topography or geophysical anomalies).  
 
1. :Start DMagic 

 
2. :Select Project > Open Project > Module3_DMAGIC  > 

Tutorial1_8 
 

3. :Navigate to > MtStHelens 
 

4. :Load the DTM and geo by clicking the ‘>>’ button 
 

5. : Select create edit georeferencing. 
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6. : Click the convert to meters button. 

 
7. : Resave the .geo file. 

 
8. :Select Tools > Compute Slope 

 
You will see a ‘Surface Slope Calculator’ window. When this dialog opens the system 
will prescan the loaded files to determine the minimum and maximum overall slopes 
in the system. 

 
9. :Enter the base name for the output slope scalar and then select 

the ‘Save Slope Surface’ button to create the scalar and geo file. A 
new .scalar file and .geo file should appear in the data set 
component list. 

 

1.9 Exercise - Using Scalars 

Data Input:   MAGNETSPC.DTM, geo, scalar and shade (when attaching scalar) 
Data Output:  shade and/or SD 
 
Scalars are typically visualized using two methods. 1) draping on a DTM, or 2) 
attaching scalar values to the DTM. 
 
This is an effective way to add a fourth dimension to a dataset  

1.9.1 Visualizing a Draped Scalar 
1. :Start DMagic 
 
2. :Select File > Open Project > Module3_DMAGIC  > 

Tutorial1_9 
 
3. :Navigate to Module3_DMAGIC  > Tutorial1_9 > 

Magnetspc.dtm 
 
4. :Load DTM, geo and scalar by clicking the ‘>>’ button 

Note the coloration of the shaded surface (based on elevation) 
 
5. :Select Surface Shader and render a shade file 
 
6. :Check the Overlay Scalar check box and select the scalar file 

(ends in .scalar) from the drag down list box (files must have 
scalar extension to be selected this way) 
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7. :Set shading parameters and then start rendering and you 
should see the dtm file being shaded based on the scalar data. 
Note the differences between the rendered shade file and the 
rendered scaler file. 

 
8. :Save the shade file and name it accordingly 
 
9. :Select ‘Assemble Fledermaus Objects’ button and the 

Assemble Fledermaus Objects window will pop up 
 
10. :Enter the file name in the Object Name text box 
 
11. :Select the DTM and geo file you used above and the shade 

file generated above from using the scalar in the shading 
process 
 

12. :Click the ‘Build Object’ button. The output .sd object should 
now appear in the SD List. 

1.9.2 Attaching Scalar 
 

1. :When assembling an SD file choose a scalar file from the 
Overlayed Scalar drag down box in addition to the DTM, geo 
and shade file 

 
2. :To see the results of this process, start Fledermaus and load 

the SD file 
 
3. :When you run the cursor over the surface in Fledermaus, you 

will see Geo Cords (x,y,z, -> scalar), where scalar = /some 
other value/ (in this case magnetics) derived from the scalar 
you attached in DMagic. 

 
E X T R A  C R E D I T : 
Given the structure.dtm and geo files and the gravity.scalar and geo files, assemble an 
.sd file of gravity data draped on topography. 

1.10 Exercise – Color Maps 

1.10.1 Simple Adjusting of a Color Map.  

We will be using a geophysical dataset as a dtm here. Specifically the San Juan 
Mountains in southwestern Colorado in the Animas River watershed near 
Silverton, Colorado.  The main volcanic features of interest are the San Juan 
and nested Silverton calderas. Technically the data should be described as a 
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scalar, but for the sake of simplicity and flow, we will use this as a dtm file 
which will allow us to use some dtm type functionality. 

 
Data Output:  resampled.cmap 

 
1. :Start DMagic  

2. :Open the Module3_DMAGIC  > 
Tutorial1_10/aeromag.dtm/geo datasets 

 
3. :Use the CMap Librarian to select the colorsinterp.cmap. 

 
4. :Under Tools click Color Map Editor. 
 
5. :The Color Map Editor user interface will open.  You should see a 

zoomed in version of the color map with labels on the right hand side 
and widgets along the left hand side. These widgets mark the interval 
breaks between the separate color intervals. Since you loaded 
colorsinterp.cmap, the Simple Color Map radio button will be toggled. 
The other type is Height Dependant Color Map. We will discuss color 
map types in more depth later. 

 
6. : In this exercise we are going to emphasize the southern flanks of a 

volcanic coldera as represented in a USGS aeromagnetic survey (Data 
provided by the USGS in Denver Colorado). As you can see, the color 
map really doesn’t define the area very well. Using the widgets, adjust 
the colors so that the shape of the caldera (which an a semi-
circular ridge cutting through the bottom of the dataset). You will 
find that there is a lot of wasted band width here and will probably have 
to compress the color bar to fit the spread of the data.  

 
7. :Click on the Save As Button and name the file resample.cmap. 

You don’t have to load the resample.cmap file right now as the changes 
you made are present in the display until you load another cmap. You 
should be able to load your new cmap in cmap librarian also. 

1.10.2  Rescaling a Color Map 
 

Data Input: IVS/Cmaps/coloursinterp.cmap         Data Output: edit.cmap 
 

1. :Load aeromag dataset. 
 

2. :Click Cmap Librarian. Navigate to the IVS/Cmap directory and 
load the coloursinterp.cmap 
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3. : Check the bounds on the aeromag dataset to see what the upper 
and lower bounds are.  Use these values in the next step. 

 
4. : Switch to Height Dependant mode. 

 
5. : Launch Color Map Editor. 

 
6. :Enter in the values that represent the data range for the aeromag 

DTM. These values will be entered into the min and max fields at 
the left of the color bar (remember to click enter). give yourself a little 
room on either side (say 0 to 450). 

 
7. Save the Cmap as rescale.cmap 

 
8. :Close the Colormap Editor and take a look at the aeromag 

dataset in DMagic 
 

 

1.10.3 Creating a New Color Map 
 

Data Output:  smooth.cmap 
 

1. :Start DMagic  

2. :Open the Tutorial1_10/aeromag.dtm & .geo datasets 
 
3. :Check the bounds on the aeromag dataset to see what the upper 

and lower bounds are.  Use these values for the starting and stopping 
“elevations”, but give yourself a little room on either side (say -0 to 450). 

 
4. :Click the Color Map Editor button 
 
5. :The Color Map Editor user interface will open. Click the 

Advanced Edit Button. 
 

6. :Click the Quick Cmap button. 
 

7. :Enter the min, max (from step 3) and interval values. Use an 
interval that gives you approximately 8 distinct intervals (50 unit 
intervals gets you close) 

 
8. :Click the OK button to close the dialogue and return to the 

advanced edit window. 
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9. :You will now customize the colormap with colors of your choice 

by filling in each interval. For example, fill in the bottom interval of 
the colormap by dragging and dropping colors from the color 
palette. This is done by clicking the left mouse button. When you 
have dropped a color onto an interval, it should turn change color.  

 
10. :Repeat the process to fill in each interval. You should see an 

abrupt break in the colors of each interval. 
 

11. :Now look a little closer at the tools available to you. Click on the 
bottom interval that you have filled in already. You should see a 
collection of squares move to the right of the filled interval. On the 
furthest right, you will see a blow up of the specified section of the color 
map. To the right of the blow up you will see four small multicolored 
squares. The two middle squares represent the interval you selected and 
the outside squares represent the two adjacent intervals. Now drag the 
color from the top square into the upper of these middle squares. 
You should see the abrupt break between intervals become a more 
gradual change.  

 
12. : Reverse your last change by dragging the color from the upper 

middle squares into the top square. You should see the change 
between the two intervals is back to being abrupt.  

 
13. :Step 12 or 13 are useful for fine adjustments involving only 2 or 3 intervals, 

but if you want to smooth an entire color map there is another tool available. 
Click the SMOOTH ENTIRE CMAP button. You will see there is also 
another button beside it that gives the option to preserve a break at 0. We will 
use this button in the next exercise. 

 
14. :Click OK button to close the Advanced Cmap Editor.  

 
15. :Click the Save As button and save the new file as smooth.cmap. 

 
16. :Click OK to close the Color Map Editor and look at the cmap and 

Data in DMagic. 
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1.10.4  Importing a Color Map 
 

Data Input: Panpac.dtm & geo and Caris Color map file (Ocean.cma)  
Data Output: PanpacImport.sd and cmap file 

 
1. :Load panpac dataset. 

 
2. :Click on the tools menu item. Navigate to the Import Color map  

 
3. :Select Caris Cmap by navigating to exercise 1_10 and select 

ocean.cma. You should see the colors change on the data. 
 

4. :Launch Color Map Editor and use the methods from above to 
apply the Caris colormap only to the data below sea level (ie. Make 
it a depth based colourmap ranging between 0 and -10700). 

 
5. :Save the colormap as ocean.cmap. 

 
Extra Credit: 
Repeat this last exercise with the gmt color map: GMT_sealand.cpt 
 

1.10.5  Adding intervals to a Color Map 
Data Input: Ocean.cmap     Data Output: sealevel1.cmap and sealevel2.cmap  

 
1. : In this exercise we will use the advanced colormap tools to add several 

colors to represent the land areas. 
 
2. :Load ocean.cmap in Cmap librarian. We want to change the Cmap 

so that there is a break in colors at sea level. 
 

3. :Start the Color Map Editor and Click the Advanced Editor 
button 

 
4. :Enter 3000 in the “Selected Maximum Value” field. And then 

click the Insert button. 
 

5. : Repeat step 2 more times adding intervals for 6000 and 9000.  
 

6. :Modify colors so that the areas above sea level are green yellow 
and red respectively. You can choose your own set of colors, just make 
sure the colors are useful in contrasting land and marine areas. 

 
7. :Click the Smooth Cmap – Preserve Zero Interval button. 
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8. :Close advanced editor and Save the Cmap as land_oceans.cmap. 

 
9. :Close Color Map Editor and view the data. 
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TUTORIAL II – ADVANCED VISUALIZATION METHODS / VISUALIZING 
COMPLEX DATA 

Dmagic and Fledermaus Used in Tandem 

1 Surface Differencing 
The surface difference operations of Fledermaus allow for the direct comparison between 
multiple surfaces. We will go through both a basic example as well as a more complex 
way to visualize this type of data. Our example will use the dredging of a channel, but one 
could easily use the same procedures for virtually any situation where one needs to 
visually investigate one surface relative to another, such as quantifying the error in the 
main vs. cross lines of a multibeam survey. 

P U R P O S E  
 
Throughout this tutorial you will: 

 
1. Perform a surface difference operation in Fledermaus 
2. Use statistical tools in DMagic to quantify the difference surface 
3. Use Dmagic and the Cmap Editor to create a qualitative means of 

viewing the difference surface 
4. View the modified difference surface in Fledermaus 
5. Use difference info to QC data coverage 

 

II 
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1.1 Exercise – Performing a Surface Difference 
Operation 

Data Input:  missiold.sd; missinew.sd                  Data Output: missdiff.dtm/geo 
  

1. :Load Module3_Advanced\1_1\missiold.sd and missinew.sd 
 
2. :Select Tools > Surface Difference from the Fledermaus menu bar. This 

will open the Surface Queries dialog. 
 

3. :Select missinew.sd as Surface # 1 and missiold.sd as Surface # 2. 
Leave the query type as “All Data”. With this set up, the positive results will 
indicate sedimentation and negative results will indicate removal of material.  

 
4. :Click the Apply button. You should see numbers appear in the volume and 

area fields as well as a new surface appear in the main Fledermaus window. 
 

5. :Click the Export Scalar and Export DTM button to save the resulting 
query surface as a dtm/geo file pair and a scalar file. Save the file as 
missdiff.dtm/geo/scalar. 

1.2 Exercise – Analyzing a Surface Difference 

Data Input:  missdiff.dtm/geo Data Output: missdiff.sd 
  

1. :Start DMagic and load the missdiff.dtm and .geo and scalar files. 
 
2. :Select Tools > Surface Statistics from the DMagic menu bar. This will 

open the Surface Statistics dialogue. This window shows you the surface 
dimensions and the data bounds, as well as showing you both a numerical set of 
statistics for the surface and a histogram of the overall data distribution. 

 
3. :Now we will take this information and use it to help us generate a color map 

that will visually indicate where and how much sediment has been removed, or 
accumulated in the time between the two surveys. Start Color Map Editor. 

 
4. :Create a color map that represents the distribution of the data i.e. it has 

a large amount of color variance around the mean of the data and less 
color variance near the extremes of the data. Also, hues of a single color 
should be used to represent either where sediment has accumulated or where 
sediment has been removed. Also, red for negative numbers and green for 
positive are usually a good choice. Save your final color map as 
missdiff.cmap. 

 
Hint: To easily create the desired color map, start the Color Map Editor, switch to a 
height dependent cmap and press the Advanced Edit button. Use the Quick CMap 
feature to create a color map with a starting elevation of -50, an ending elevation of 
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50 and an elevation interval of 50. Once the color map is created, specify green for 
positive values and red for negative values. 

 
5. :Using the shader, drape the scalar file over the missinew surface in 

order to put the data in context. Assemble the data as a Fledermaus 
object and call the file misDifNew.sd. Take a look at this surface in 
Fledermaus. Is all of this data real? 

 
Note: You could also approach steps 5 and 6 by instead changing the surface 
difference.dtm to a scalar file using windows explorer or whichever means in the 
platform you are using. 

 
Extra Credit: 
Use the Mount St. Helens datasets to calculate the volume and surface area of material 
removed or displaced during this eruption. Also use Dmagic to judge if there is a systematic 
bias between the two datasets. 

1.3 Exercise – Points, Lines and More… 

P U R P O S E :  
 

This exercise will expand on the data loading to cover vector objects 
and is also designed to reinforce your ability to work with images. 
You might even learn something about plate tectonics! 

1.3.1 Using Image Import To Create A Base Map 
 

Data Input: world.dtm, geo, tif Data Output:  world.sd 
 

1. : Start DMagic  

2. : Open the Module3_DMAGIC  > Tutorial 1_3 project. 

3. : Import the Arcview grid called world. You’ll find this in the 
world folder. 

4. : Import world.tif. You want to select the world.dtm in the texture 
mapping option to create a texture mapped .sd file called world.sd. 

5. : Load the .sd file into Fledermaus. 

6. : We are finished with Dmagic for this Exercise; you may close it. 

7. : You should see a 3D image of the earth’s surface. This may take 
a few moments as it is a large file. 
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1.3.2 Loading Line Objects 
 
1. :Now we are going to delimit plate boundaries by importing an xyz file. 

The point file will be converted to a 3d line. In Fledermaus select File 
> Import > Import Lines. 

 
2. :The add lines dialogue should now have opened. Click the Choose 

File button to load plates.xyz from the lines directory. We won’t 
have to modify any other entry field here. So click OK. 

 
3. :We will now repeat the last step and import faults.xyz. You will 

find the line data in this object tend to play peek-a-boo. So you 
may want to select the faults object and then click the drape 
button, which will drape the lines on the surface. 

1.3.3 Loading Arcview Shape Files 
 

1. :We will now import an ESRI ARC theme. Select Import > Import 
ArcView. When the loading window opens, select SAGeo.shp from 
the ESRI folder as the input file. In the conversion controls area, 
set the color by Attribute field to “glg”. 

 
2. :Once the shape file is loaded, set the color by pull down to 

attribute. You should see now that a generalized colored geological map 
of South America is visible. Try to toggle the closed polygons check 
box.  

1.3.4 Loading Point Data 
 
1. :Select File > Import > Import points.  

 
2. :Load the file Quakes.xyz from the points directory. In the 

variable order set the format to “y x z color” to reflect a point file of 
“lat lon depth (of hypocenter) and magnitude (which the points 
will be colored by)”. In the Cmap field, navigate to the IVS/Cmaps 
and choose colorinterp or some other suitable color map. 

 
3. :You can modify the vertical exaggeration to see the points a little 

better, look at the plate boundary on the west coast of south America, 
the distribution of point data clearly delimits the subduction zone.  Click 
on the drape points to project them to the earths surface and note 
the distribution of earthquakes versus the plate boundaries. 
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4. :Repeat step 4 and load the volcano.txt file. This file has only x and y 
information though.  



F L E D E R M A U S  T R A I N I N G  

24 

TUTORIAL III - WORKING WITH AVERAGE GRIDDER 

Average Gridder 
Introduction 

unctionality of this software is two-fold. Traditionally Average Gridder has been used as a standalone 
gridding package based on weighted average gridding. Extended functionality of this tool now provides 
a quick check for data quality before complex area based processing is attempted.   
 

 

P U R P O S E  
 
Throughout this tutorial you will: 

 
1. Grid a file 
2. Export a binary file 

 

 

III 

F 
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1   Gridding a File 
 
Gridding a file converts a point file into a DTM for manipulation in DMagic and eventually for 
visualization in Fledermaus. 
 
This process is mandatory for gridding raw ASCII data to produce a DTM.  
 
If the data is a gridded ASCII file, you can instead, use the import surface option in DMagic (see Tutorial 
I - DMagic). 
 

1.1 Exercise – Gridding a File 

Data Input: (Allbin.asc) ASCII or binary xyz file      Data Output: (allbin25 and allbin10)DTM and 
geo files. 
 

1. :Start Average Gridder 
 
2. :Click File > Add File To Grid   
 

‘The Add Files to Grid’ window will appear. 
 
3. :Select allbin.asc from Module3_AGRIDDER > Tutorial1_1 and select the ‘Open’ 

button to close window 
 

NOTE:  It is easy to add multiple input files to the list of files to load, the Open Dialogue box operates 
supports the same features as any windows dialogue box with regards to file selection (i.e. shift and control 
keys). Multiple files will be combined into one DTM 

 
The software is now able to automatically detect any supported data format, OR the user can select the file type 
from ‘File Format’ drag down menu.  
 
Formats now supported: 
 

NAVO GSF 
SHOALS Out 
RAN HTF 
CARIS HDCS 
Generic Ascii 
CnC Trace 
Generic Binary ( IVS ) 
Ocean Mapping Group -
 .merge 

Kongsberg Simrad Neptune  
SHOALS 1K 
SHOALS Hydro/Topo Airborne  
ATLAS SURF  
Sondeur MultiFaisceau (MultiBeam 
Sounder)  
VISE 
PFM 

 
For ASCII files, the xyz input field allows for you to swap columns to match input data (lat lon vs. x and y) and 
allows the user to invert z values (if the input data uses the positive down convention).  
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You may also read multivariate files by adding the extra parameters in the file format area. For example, 
an ASCII file with columns for x and y position, sounding and magnetic data. These are advanced 
options that we will take a look at this later. 
  
There are several gridding methods and the software is set to use a weighted moving average.  
 

 
4. : We will create a grid with a cell of 25 and a weight field of 3 (these should be the 

default – double check to make sure these values are in the proper fields). 
 
§ The cell size field allows you to modify the size of each grid cell;  
 
§ The weight diameter denotes how the value of each cell affects the value of neighboring 

cells.  
 
§ A value of 3 is a nearest neighbor operation, while a value of 5 uses a weight field with a 

radius of 2 cells.  
 

§ Increasing the weight value will remove holes in data with an interpolated value, but will 
also smooth the data.  

 
§ These two buttons are useful when used in tandem, as they allow the user to visually 

determine the proper gridding parameters. If any parameters are changed, a rescan of the 
file will be required.  

  
5. :Select the ‘Scan Data’ button to determine the bounds of the input file(s) and 

how big the resulting surface will be.  (Note that the Notifier at the bottom of the 
window will indicate when the file scan is done.) 

 
6. :Press the ‘Plot Data Points’ button located at the bottom of the window.   

Here you may view the distribution of the raw data points on the screen. (The Notifier will state 
when the plotting is done and the number of points in the loaded file(s).) 

 
7. :Click the Show Grid toggle button to on.  

For the highest resolution, with this type of data, a grid size should be chosen so that each point 
falls in its own cell. Which is not the case here, but should result in a smooth surface anyway. 

 
8. :Now we will convert the series of points into a surface by pressing the Convert 

button. (The Notifier will indicate when the DTM creation is done) 
 

9. :Click the Plot DTM button to see the result of your efforts. Zoom in and out 
using the middle mouse button and pan using the left mouse button. 
 

10. :Save this DTM by clicking the Export DTM/GEO selection on the File menu, 
and selecting the location you wish to save. Name the output allbin25.  
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You only need to enter the base name, no extensions are necessary. 
 

11. :Repeat the steps 5 through 11 using a bin size of 10 and a weight field of 5.  Save 
the results as allbin10. 
 

12. :View the results in DMagic and Fledermaus 

1.2 Exercise – The ‘Set Bounds’ button 

Data Input: (Allbin.asc) ASCII or binary xyz file      Data Output: (allbin25small)DTM and geo files. 
 

This tutorial will show you how to grid a subset of a loaded file. 
 
1. : Select allbin.asc from Module3_AGRIDDER> Tutorial1_2 (we will use defaults) 
 
2. :Use the right button to create a square around the shoal in the northwest corner of 

the dataset.  The right button is used for delimiting areas in average gridder and if a 
polygon is selected you will see that the Use Custom Bounds check box will be Checked. 

 
3. :At this point you can click the convert button for DTM creation but we’ll investigate the 

custom options a little more here. Click the Set Custom Bounds button. This button 
allows the user to employ several methods to modify the way the bounds are determined 
for the output DTM. You should now see a Set Bounds window, with several tabs available 
reflecting how you want to delimit your custom data bounds. In this exercise we have 
chosen to use Custom Data Bounds method. The bounding box coordinates match up with 
the indices of the polygon we described in the main window. You can always changes these 
values as required. 

  
Other methods are:  
§ a box around a central point (Centered Box); and  
§ by positioning the lower left hand corner of a user defined box (Corner and Size).  

 
The user will immediately see the bounds reflecting the bounds of the data, or any changes made 
using the set bounds button. You can select any of the 3 custom bound methods to extract required 
data as they all reflect changes you have made in your custom bounding box.  
 

 
4. :When you are finished click the OK button 
 
5.  :Repeat steps 6-11 in Tutorial 1.1 and name the output as allbinSmall. 

 
E X T R A  C R E D I T :  
In the extra_credit folder you will find:    Loihi1, loihi2, loihi3, loihi4 and info_loihi.txt. 
Create a single dtm containing these files. Constrain the data to the shoal areas in the west where 
there is dense data. 
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1.3 Exercise – The ‘Configure’ button 

Data Input:  (gulf_of_maine.xyz) ASCII or binary xyz file       
Data Output:  (gulf_of_maineDTM and geo files. 

 
1. : Load gulf_of_maine.xyz from Module3_AGRIDDER> Tutorial1_4 and scan the 

file. 
There are several differences between this file and the one we have been working with.  See if you 
can figure out what they might be…  
 
look at the data ranges. This data has been stored as a file with the z positive down convention and 
so will have to be treated a little differently. You will also notice that the coordinates are 
geographic. 

 
2. :In the cell size field use the value of 0.001 or approximately 81m (267 

international feet). 
 

3. :To change the sense of orientation for the z variable, we will have to use the 
Configure button, located below the Input Files to Grid window. Click this button 
now. 

 
4. You should now see the Input File Configuration window. The function of this window is 

to allow the user to fine tune how Average Gridder treats various types of input files. 
Some file types such as GSF can be very complex while files such as the gulf_of_maine 
ASCII file are fairly simple. Look at the file type field, it should say ‘Generic ASCII’.  
You should also see a table representing the various parameters of the loaded file(s). Take 
a look at this table now as we describe what each column means. 
 
Name: There should be three of these (ASCIIFIELD 1,2 and 3). Each representing one 
the fields in each physical record in the ASCII file. More variables in the file will result in 
more rows in the table. 
 
Mapping: This defines how Average Gridder uses each file field to construct the output 
grid. You should see that rows 1, 2 and 3 display ‘x’, ‘y’ and ‘value to grid’ respectively. 
 
Modifier: Some values can be altered by necessity so that the resulting grid conforms with 
data you may already have on hand or to appear correctly in later visualization. We will 
come back to this in just a few moments. 
 
Min: The minimum value in the specified field. 
 
Max: The maximum value in the specified field. 
 

5. :Select the Modifier pull down for “ASCIIFIELD 3/Value to grid” and set it to 
Invert. This will invert the z value from being positive depths to negative depths. 
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6. :If you have time now, go through the steps to produce an sd and view the final 
product in Fledermaus. 
Hint: The user can also use the data range to constrain the z range of the z value used to construct 
the DTM. (This option is a very useful spike removal tool by limiting the z bounds so that all 
values outside a reasonable set of values will be discarded).  

 
7. :Try the last exercise but set the minimum z range to -10 and plot the data points. 

 

1.4 Exercise – The ‘Histogram’ button 

Data Input: (gulf_of_maine.xyz) ASCII or binary xyz file      Data Output: NA 
 

The histogram button is located in the Set Bounds Window. The hystogram provides the ability 
to see the distribution of the data points. Data with spikes should be quickly identified. You 
can use the histogram to visually limit the z bounds of the DTM by setting range of the data (a 
graphical approach to the last exercise).  

 
1. : Load gulf_of_maine.xyz from Module3_AGRIDDER> Tutorial1_3 and set the 

appropriate parameters and scan the file 
 
2. :Click on the Set Bounds Window 

 
3. :Click the Histogram button. 
 
4. : Desired ranges are set by moving the cursor to desired left limit of the 

histogram and clicking the left mouse button and to the right limit by clicking the 
right mouse button.  

 
Lets try this using bounds of approximately -25 and -50. As you move the bounds you will see the 
numbers in the selected bounds change. The left and right limits will be indicated by green and red 
flags respectively at the top of the histogram window.  

 
5. :When you have your final values selected, apply the changes by selecting the OK 

button.  The user can open the histogram again to continue to fine tune the histogram by 
repeating the previous steps, if desired. 

 
6. :Export a dtm and geo file and view the results in DMagic. Pay special attention 

to the bounds of the dataset.    
 

 



F L E D E R M A U S  T R A I N I N G  
 
  
 

 30 

1.5 Exercise – Loading Multivariate Files 

Data Input: (bathymag.xyza) ASCII multivariate file      Data Output: magnetic.dtm/geo 
 
1. :Load bathymag.xyza from Module3_AGRIDDER> Tutorial1_5 
 
2. :Adjust parameters so that the cell size is 50m and set the data format to xyza. 
 
3. :Scan the file with z as the attribute to grid. Take a look at the output grid. 
 
4. :Select ‘a’ as the value to grid and take a look. 
 

E X T R A  C R E D I T :  
Using this data along with Average Gridder and Dmagic, produce an .sd file in Fledermaus that 
represents the magnetic data draped on the bathymetry. You will have to produce both a scalar and a 
dtm in average gridder. 

1.6 Exercise – Exporting a Binary File 

Data Input: (61mba*.d0*) ASCII or binary xyz file       
Data Output: loihi.bin  Binary xyz 

 
This operation allows for the conversion of an ASCII file into an IVS binary point file. The conversion 
of the ASCII file into the binary file will speed up the reading of large files and should greatly reduce the 
size of the file. 
 
1. :Start Average Gridder 
 
2. :Load the *.d01 and *.d02 from Module3_AGRIDDER> Tutorial1_6 
 
3. :Select the proper file parameters and Scan the file. 
 
4. :Select File > Export points. This will bring up a save dialogue box. 

 
5. :Leave the Export Options set to convert each file individually. You do have the 

option to Merge all input files into one output file which will combine loaded files together 
in one output file. 

 
6. :Save the file as loihi.bin and choose “Generic ASCII” for the output format.  

 
Selecting the Generic ASCII option will rewrite the loaded data as one file and is therefore useful if 
merging ASCII files is the desired operation.  
 
The other types are all binary formats (IVS, CNC and STB), which will merge and convert the loaded data 
files into one binary file. The binary file will be smaller and thus faster for any future loading and gridding. 
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7.    :Click the Browse Button to Select the Output file name. This will open a files save 
dialogue box.  You can use this to navigate to the desired save directory and name the 
output file. 
 

8. :When the path and filename and format have been selected, select the save 
button, to write the new file. 

 
9. :Repeat Step 4-8 but select IVSBinary as the output file format. 

 
10. :Compare the file size of the input ASCII and output ASCII and binary files. 
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Tutorial IV – Image Viewer 

ImageViewer 
Introduction 

mageViewer is a supporting application to handle some of the typical imagery related actions that need to 
be done in a visualization system. What makes this image viewer a bit special is that it is much more 
aware of georeferencing data in images than most simple viewers and it can read imagery and DTM data 

from IVS’s TDR (Tagged Data Representation) files. In its most basic form, ImageViewer is simply an 
application to view images and their associated georeferencing data. However a number of tools are included 
that that support some of the common image processing needs such as cropping, resampling, and basic 
imagery operations including the ability to turn portions of the image transparent. 

P U R P O S E  
 

Throughout this tutorial you will: 
 

1. Load, convert, and save images in several formats. 
2. Creating geotif images. 
3. Perform basic operations such as cropping, resampling, and georeferencing. 
4. Make parts of the image transparent. 

 

1.1 Exercise – Loading/Geo-referencing an image 
 
In this exercise you will use imageviewer to load several images and verify that they have geo-
referencing. You will also add geo-referencing and save out geotifs.  
 
Data Input:  vermillion.tif, lidarref.dtm,  Data Output: geotifs, etc. 

   Data courtesy of Optech Inc. 
 

1. :Start ImageViewer 
 
The basic imagviewer interface consists of a tabbed information bar at the top to display pixel and 
georeferencing information and an image display region below that.   

 
2. :Select File > Open… and load the file “vermillion.tif” from 

Module3_ImageViewer\1_1 
  

I 
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Verify that it loads properly and you can see the image. Note the tabbed information display area 
located just above the image. This image is not currently georeferenced. Thus the geo-coordinates will 
be zero.  
 
3. :Select Edit > Georeferencing… and enter the coordinates 
  
This will bring up a dialog box for you to enter the bounds of the image. You will need to type in the 
coordiates which are:  

X: 500000 501310, and 
Y: 1000000 1001077 

  
The click the OK button to assign the coordinates to the image.  
 
4. :Examine the displayed geo-referencing information in the display above the 

image. Note how it updates as you move the cursor. Change the tab to the 
image info and examine that data.   

 
Note that at this time you can not pan or zoom displayed image. The entire image will be rendered 
to fill the available display region. Even though you may not see all the pixels of a large image in the 
overview, any operations you perform on the data is always done on the full resolution data stored 
behind the scene. 
 
5. :Select File > Save As… and save the image as “vermillion-new.tif” 
  
In the dialog select the output format to be a tiff image. This will automatically write a geotif image with 
the coordinates you saved. 
 
 
6. :Quit and re-run imageview and load the file you just saved to verify for 

youself that it did indeed create a geotif image. 
  
Unlike the first time the geographic coordinates should be there.  
 
7. :You can create a tiff word file from the image by selecting File > Write TFW 

> Write TFW lower left origin. 
  
This will create a new file in the same location as the current image with the same filename but with a 
“tfw” file extension.  

 
8. :Try a simple transform: Image > Transforms > Flip Vertical 
 
When you perform this operation the image should flip vertically. If you do it a second time the 
image will flip back. There are a number of useful imagery operations – feel free to experiment a 
little. 
9. :Select File > Open… and load the file “mtsthelens.dtm” from 

Module3_ImageViewer \1_1 
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Note that you can load Fledermaus TDR files such as many sd, dtm, and shade files. Given this file is 
actually height data, imageviewer will turn it into and 8bit greyscale image. You could save this out as a 
tif file if you like for modification in another package. We will do more with this in the 3rd exercise using 
a TDR shade file. 

 

1.2 Exercise – Prepare an Image for Draping 

One of the more common uses of this tool is to prepare an image to be draped on a surface. Some 
images such as digital charts that have been digitized from paper products are extremely large and 
have unnecessary high resolution for the detail they present. Imageviewer can be used to conveniently 
crop out an area of interest and rescale it to a more useful size. Once that is done we texture map it 
onto the surface of a DTM. 
 
Data Input:  portsmouth.tif  Data Output: chartsection.tif 

   Data courtesy of Sallow Survey 2000 
    
 

1. : Start ImageViewer and select File > Open… and load in the file 
Portsmouth.tif from the exercise-2 directory. 

 
After a short time the overall chart area should be shown. For the purpose of this tutorial we 
will be interested in extracting an area near New Castle Island.  
 

2. : Use the left mouse to click and drag a box around the area of interest. In this 
case we want the entrance of Harbor to the right of NewCastle Island.  

 
If you want precise control of the coordinates you can adjust them in this dialog. You can also 
directly specify the region of interest by selecting Select > Set Selection… which brings up a 
dialog for you to enter the appropriate values. 
 

3. : Select Image > Transforms > Crop to cut the image to the selected bounds. 
 
This will leave you with the much smaller region extracted from the original large image file. 

 
4. : Save the resulting image via the File > Save As... option. 

 
Make sure the save format is a tif image file and give it the name of smallchart.tif. 
 

5. : You are now ready to use the image.  There are many things you can try, but 
we’ll suggest three: 

 
 

6. : Run Fledermaus, and load the Portsmouth-ll.sd file. Then select File > 
Import > Import Image and load the smallchart.tif. 
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The flat image will cover up the multibeam data from the harbor. To knock a hole in the 
image select the smallchart object and turn on the show masked area toggle. Finally click the 
“Compute Mask” button to actually knock the hole in the image. Now you have a combined 
scene with the flat imagery and multibeam. 
 

7. : A second thing to try is to drape the image directly on the multibeam data. 
Run dmagic and select File > Create Textured SD File… 

 
Make sure the save format is a tif image file and give it the name of smallchart.tif. 
  

10. : In the dialog presented load the smallchart.tif file which should be a geotif 
image and for the input SD file select Portsmouth-ll.sd from the 
Module3_ImageViewer\1_2 directory. Then give an output SD name and click 
OK. 
 
This should result in a new SD file being generated. Load it into Fledermaus and take a look at 
it. 

 
11. : Finally we’ll create a SD file similar to the draped one above but this time 

we’ll add illumination to the imagery before draping. 
 
12. : In order to do this we’ll need to break up the Portsmouth-ll.sd file into it 

DTM/Geo/Shade components. Use the Project > Import From .sd or .scene 
option and select the Portsmouth-ll.sd file.  

 
We need to do this because in order to use the cut and drape imagery option well will need a 
DTM object to crop and resample appropriately. 

 
13. : Run dmagic and select File > Import Imagery > Cut and Drape Imagery. 

Select the smallchart.tif again and make sure the “Match georeferenced 
regions and rescale DTM to image resolution” toggle is selected. In the 
“DTM to Process” pulldown select the Portsmouth-ll.dtm object. The click 
OK. 
 
This will result in three new files being created which include Portsmouth-ll-out.dtm, 
Portsmouth-ll-out.geo and Portsmouth-ll-out.tif (which you won’t see in the component 
display list). 
 

14. : Load the new Portsmouth-ll-out DTM and Geo into the main display. Then 
click the “Surface Shader” button to bring up the shading dialog. 

 
15. : In the shader toggle on the “Overlay Image” option and select the “…” 

button to bring up the file selection dialog to specify the image to drape. Select 
the Portsmouth-ll-out.tif (NOT the original smallchart.tif). Finally click “Start 
Rendering” to shade the surface with the illuminated imagery. Save the 
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resulting shade file and assemble a SonarDTM object with Portsmouth-ll-
out.dtm/geo/shade.  

 
16. : Run fledermaus and load the two SD files you produced. The first one 

being the straight drapped imagey and the second one the illuminated 
imagery. 

 

1.3 Exercise – Working with a TDR Shade File. 

In this exercise you will use imageviewer to convert a TDR shade file to a tif image, modify it, and 
turn it back into a shade file again. The important thing to realize is that a shade file is nothing more 
than an image.  
 
Data Input:  mtsthelens.shade  Data Output: mtsthelens.tif, mod-mtsthelens.shade, mod-

mtsthelens.sd 
 

 
1. : Start ImageViewer and select File > Open… and load in the file 

“mtsthelens.shade” from Module3_ImageViewer\1_3. 
 
A TDR shade file contains the same type of imagery data that a tif file does thus it can be easily 
loaded into ImageViewer. 
 

2. : Select File > Save As to save the image but change the format to a tif image 
and give it the file name “mtsthelens.tif” 

 
This will convert the TDR shade data into a standard tif image file. 
 

3. : Use any 3rd party tool to modify the saved tif image (Such as Windows paint, 
Photoshop, or Gimp.) 

 
Now any imagery manipulation tool can be used to modify the image as long as you don’t 
change the image dimensions. However, to facilitate this exercise a modified tif image has 
already been put in the directory called “mod-mtsthelens.tif” which has been modified to add a 
title and logo. 
 

4. : Convert the modified tif file back into a shade file. Select File > Open to load 
the “mod-mtsthelens.tif” (or you own modified tif file) back into ImageViewer. 

 
5. : Select File > Save As to save the image but make sure to change the save 

format to “TDR Shade File”. Save the file as “mod-mtsthelens.shade” 
 
This image has now been converted back into a TDR shade formatted file. 
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6. : Finally use dmagic to assemble the dtm, geo, and the new shade file you 
created into a SonarDTM object. Load it into Fledermaus to see the results. 

 
Be careful when assembling the dtm, geo, and shade pieces that you use the “mod-
mtsthelens.shade file and not the default original mtsthelens.shade file. 
 

 


